electrical

Sort by:

Engine Light Comes On

I have a HD 883 w/1200 upgrade, 2006 model, only 700 miles on it. My engine light is coming on and off during the ride. What could be the problem? The bike was purchased in 2006 and sat stored by the previous owner. Via Email Hi Cheryl, Depending on how it was converted to 1200…

Read more »

Heritage Softail Giving Me Grief

Hello. I have an ’02 Heritage Softail Classic that is giving me grief. Bike particulars: basic stock bike screamin eagle pipes (sounds like a Harley is supposed to) aftermarket 6 speed tranny a few chrome goodies lizard lights (kinda cool) Problem: Just out of the clear blue the bike dies, completely! No lights, no starter,…

Read more »

Tour-Pak Lens Replacement

Over the years’ I’ve replaced the lens on my FLHT to smoked, and have now decided to replace the Tour-Pak lens as well. I purchased a pair of smoked lens and I’m not sure how to accomplish this. I have all the HD service manuals and none of them go into any detail as to…

Read more »

Starting Problems 2006 FLSTCI

I have a starting problems 2006 FLSTCI and just put a 95 big bore kit in with SE 211 cams and now the bike will not start. Trouble shooting we found it has no spark. It had a power commander 3 USB in it and I removed that and still nothing. Any suggestions? Via Email…

Read more »

Starter Problem with 06 Fatboy

I have a starter problem with 06 Fatboy. I went on a ride the other weekend when the starter engaged by itself going down the highway. I was able to get to the side of the road and shut the bike off. I turned the ignition switch on and the bike would start without hitting…

Read more »

Electrical Issue

I have a 1999 FLHTC I just had new cams and replaced the chains to a gear drive. I had the Harley dealer do it and when I test drove it the thing back fired a bunch of times but once real bad. The dude forgot to tighten the muffler clamp to the motor. Since…

Read more »

Starter Issue

I’m kinda stuck between a rock and a hard place. Just went out and got on my 2000 Glide, turned on the switch, waited for the engine light to go out, hit the start and everything just died! Nothing, nada! Checked all the fuses and connections at the battery all seem to be alright. It’s…

Read more »

1981 FXE Starter Wiring Issue

I have a 1981 HD FXE. The issue is in the wiring system. If I have the wiring hooked up properly for starting, it keeps cranking. I then have to disengage the wire from the battery for it to stop. I have changed the relays, breakers, solenoid, starter, double checked all of the wiring according…

Read more »

Speedo Issue

First let me say, thank God for you guys. It’s great to have an alternative to being bent over by the “Stealership” wrench jockeys that are more into selling parts than anything else. Second, I have an electrical problem and a biker friend at work suggested that you might be just The guys to ask…

Read more »

2007 Ultra Starter Problems

I am having problems starting my 2007 Ultra starter. Everything seems to be working correctly up to the point where you push on the starter switch and then all I hear is the starter relay clicking. I have checked all connections that I know of and have found nothing loose. Battery is good but starter…

Read more »