Speedometer Pegs Itself

Question for Fix My Hog I have a 2005 Heritage Softail. The speedometer pegs itself when you turn on the ignition switch then returns to normal and will not read at all . I check all the wiring to insure nothing was loose and also the speed sensor . Any thought on what else I can look at to fix this problem?

Via Email

Fix My Hog Answers What you describe, sounds like you have a failing speedometer.

Related Fix My Hog Videos:
Harley Digital Speedo Removal

Have more questions? Check out our Q&A index page to find some answers.

Discussion
  • (will not be published)

7 Responses to “Speedometer Pegs Itself”
  1. Rod Ward
    Rod Ward

    I have a 2006 dyna wide glide doing similar thing but when accessories on it pegs and turn ignition switch on it jumbs 5miles an hour

    Reply
      • Joe
        Joe

        Try this. When you shut down your bike hit the engine kill switch then turn the ignition switch off. Upon start up, turn on ignition and then turn on the ignition kill switch. Sounds crazy but if I follow this procedure my 1999 FXDLR my speedo functions properly. Otherwise it bounces all over. Also pull the speedometer sensor out of the transmission and clean any accumulated debries. Before purchasing a new speedo, I would give this a try.

        Reply
  2. michael
    michael

    I have a 2017 ultraclassic an I’m wanting to put 4in handle bars on .. any videos for how to do that ..??

    Reply
    • Customer Service
      Customer Service

      Hello Michael,

      That’s a great question!

      The ‘Ask an Expert’ section is currently for members to our online community. We do have a promotional offer if you are interested. This would include access to expert advice (like this), plus discounts, hours of Premium videos, etc. Please feel free to take a look. You can message us right back with your question if you decide to become a member and you will have a response within 1-2 business days from our experts!

      Please follow the steps below to receive the annual membership at the introductory rate:

      1. Click on the email link: https://go.fixmyhog.com/C23059
      2. Click on the Premium Membership offer.
      3. The Checkout page will display your Premium Membership purchase.
      4. Fill in your Billing Details and create an account password.
      5. Fill in your debit/credit card information.
      6. Finish by clicking Complete Order.

      If you have any further questions, please contact Customer Service at 1-855-231-0653 at your earliest convenience, or chat with us on our site.

      We greatly appreciate your business!

      Sincerely,

      Julia
      Fix My Hog Video Membership

      Reply
  3. Donald Campbell
    Donald Campbell

    My 2001 FLHT did that twice. It was the speedo sensor in the transmission. An aftermarket replacement sensor Permanently fixed it – So far!

    Reply
  4. Charles pothier
    Charles pothier

    I had the same problem with my 05 Ultra Glide. It would Peg and then after awhile it would just stay there. I replace the speedo and everything works fine now

    Reply